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Welcome to OnTheAir Live

Remarks

In this manual, pop-up menus will be indicated as: File > Save As. The word “File”  before the sign 
“>” indicates the menu from the menu bar. The information after the “>” sign is a command that 
you can choose within the menu.

You can visit our web site www.softron.tv for information about updates as well as to contact us 
for support. 

In	the	first	part	of	this	manual,	we	will	briefly	introduce	you	to	OnTheAir	Live.	You	will	learn	about	
the	different	configurations	and	how	to	install	and	launch	the	software.	

 I
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What is OnTheAir Node ?
OnTheAir Node is the next generation playout/ingest engine from Softron. It has been designed 
to	fulfill	a	need	in	the	broadcasting	industry	for	an	inexpensive,	reliable	and	customizable	
video	server	based	on	off-the-shelf	technology.	The	concept	was	to	make	OnTheAir	Node	
completely faceless (apart from the System Preferences pane) and completely open to third-
party	applications	along	with	Softron’s	own	applications	as	well.	It	is	controlled	through	Telnet,	
a very open, standards-based protocol used in many broadcasting equipment. This means the 
node can be controlled from any application on any platform to provide seamless playout and 
ingest functions.

Reliability
OnTheAir Node has been designed to launch automatically at startup and to resume operation, 
even after a crash or power loss. A log of everything that is played is maintained and available 
for the user. It is not necessary to have a display monitor connected to the Node server which 
makes it ideal for using on headless servers like the Xserve.
It has been tested with a media catalog of more than 500,000 video clips.

Media Cataloging
One of the challenges of having client/server setups is to make sure the client knows 
exactly what media are available on the server at any time. This is achieved by providing 
synchronization information to the clients even if they are disconnected for long periods of 
time. Information on the clips is provided as XML, making it easy for any application to retrieve 
the	clip’s	characteristics	like	video	codec,	audio	sample	rate,	creation	date,	last	modification	
date,	finder	label	etc...	It	also	automatically	validates	the	clips	to	make	sure	they	are	compatible	
for playback. If not, a detailed description of the problem is available to the client applications.
The	Node	will	also	automatically	retrieve	a	file	even	if	it	has	been	moved	or	copied.	If	the	
original becomes unavailable, a copy will be used instead and this is completely transparent to 
the user.

Clip Attributes
Another revolutionary feature of the node is that it publishes available clip attributes, so that 
every client application knows exactly what plugins are available on the node and what their 
possible	values	are.	An	example	is	the	GPICommander	plugin	(the	first	plug-in	to	be	released	
with the Node) which advertises all its inputs and outputs along with their state.
When	the	node	is	playing	a	clip	and	its	attributes	are	different	than	the	current	value,	the	
plug-in will automatically be called to adapt its state. So for instance, if a clip is marked with 
an	attribute	of	“GPICommander	Output	1	On”	and	the	current	value	is	off,	then	the	appropriate	
output will be turned on automatically when the clip begins. That makes it very easy to assign 
attributes to clips and does not require to use manual actions anymore. Another available 
attribute	is	the	logo	overlay.	The	clients	know	exactly	what	logo	overlay	files	are	available	on	the	
node and can select which one to apply on each clip.

About OnTheAir Live

1.1 X Some quick facts

1
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Playout
OnTheAir Node uses, under the hood, our well-knows playback engine that provides seamless, 
reliable SD and HD playout functions while adding features like multi-lingual audio support, 
station logo overlay and last but not least, alpha support for ARGB playback (playing a movie with 
its key on a separate output).
Each host computer will originally support two nodes to allow for multi-channel playout and/or 
ingest.

Ingest
While the ingest module for the Node will not be available until this summer, it will be completely 
integrated in the Node behaviour, so each node will be able to either ingest or playout according 
to its schedule (or the remote control commands).
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This manual concerns OnTheAir Live. OnTheAir Live is the free client application for OnTheAir 
Node a client-server playout application.

There are also some standalone playout solutions available. OnTheAir Video, OnTheAir Video DV 
and OnTheAir Video Express, each with a speciality. Here is a quick description of each of them so 
you	can	make	your	choice.	But	to	have	an	extensive	view	of	the	differences	between	each	version,	
you should refer to the following page of the Softron website: http://www.softron.tv/products/
playout_standalone/compare.html

1.2 X About OnTheAir Video - DV - Express

The FireWire Version of OnTheAir Video called OnTheAir Video DV works (only) with 
any FireWire Converter. With the multichannel video option, you can output up to 4 
video signal from one computer (with additional FireWire card and the appropriate 
number for FireWire converter). The strength of OnTheAir Video DV is that it is 
very light to run and can run from a laptop, Mac mini, with very few memory. It has 
the Scheduling option making it possible to use for 24/7 broadcast operations. 
Compared	to	OnTheAir	Video,	it	doesn’t	have	however	the	Logo,	HD,	or	multi	
language	options.	It	only	plays	dv	stream	files.

OnTheAir Video Express is the “entry-level” playout application. Its strength relies in 
that	it	can	output	any	file	QuickTime	can	read	to	any	available	Video	output.	If	you	
can	open	a	file	with	QuickTime,	you	can	output	it	with	OnTheAir	Video	Express.	It	
can	also	read	ARGB	files.	This	means	that	from	After	Effects	or	Motion	project,	you	
can	export	a	file	in	Animation	codec	or	Apple	ProRes	4444	and	overlay	that	file	on	
top	of	an	incoming	signal,	making	it	a	really	efficient	Character	Generator	with	tools	
you	know.	As	QuickTime	is	used	to	output	the	video	(and	not	our	own	engine	as	with	
OnTheAir Video), OnTheAir Video Express is not a playout application recommended 
for	24/7,	it	is	rather	intended	at	Live	shows	or	productions.	It	also	doesn’t	have	
some options like the Scheduling or Logo overlay option.

OnTheAir Video DV

OnTheAir Video Express

OnTheAir Video

The PCI version of OnTheAir Video uses our own playout engine that has been 
developed	and	improved	since	it	was	first	used	in	2004.	It	has	proven	very	high	
reliability and therefore is the ideal companion for broadcast 24/7 or live shows. 
OnTheAir	Video	can	playout	most	QuickTime	codecs	(provided	they	are	i-frame)	and	
has some advanced features (some are optional) such as Logo overlay, multilingual, 
Actions (to trigger external devices such as GPI or Character generators, etc...), 
Scheduling, ... For Live shows OnTheAir Video also has the Cue mode which will 
make	it	a	very	easy	to	use	video	player	to	start	Video	subjects.
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OnTheAir Live and OnTheAir Manager are 2 Mac OS X client applications that can control 
OnTheAir	Node.Each	have	their	specifities,	and	in	short	OnTheAir	Live	is	for	Live	production	and	
OnTheAir Manager is for 24/7 scheduling of OnTheAir Node.

1.3 X OnTheAir Live, OnTheAir Manager and OnTheAir Server

OnTheAir Live is bundled free with OnTheAir Node. You 
can then install it on any number of client workstation. One 
OnTheAir Live can control multiple OnTheAir Node.

OnTheAir Live is typically to be used in Live production 
to	start	news	subjects	with	Cue	mode,	A/B	Roll,	multiple	
playlist creations, etc... The great advantages compared 
to OnTheAir Video is that multiple clients can see what is 
playing,	so	you	can	have	your	producer,	and	journalists	
seeing what is the clip that is currently playing without 
being able to control the playout, and have only the operator 
controlling the playout. The A/B Roll is also a unique feature 
in	OnTheAir	Live,	where	you	can	have	the	next	2	subjects	
ready to play.

OnTheAir Live

OnTheAir Manager is another client application for OnTheAir Node. This one is not free. This 
the application that enables you to schedule your playout for 24/7. It has a calendar style user 
interface, and have some great new features like hierarchical playlists, clip categories, inherited 
attributes, repeated events, Live clips, etc...

One OnTheAir Manager can take control of multiple OnTheAir Node. But the schedules and 
playlists on one OnTheAir Manager client can not be shared among multiple users as they are 
stored locally. If you want to be able to have multiple clients modifying the same schedules and 
playlists, you will need OnTheAir Server

OnTheAir Manager
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When creating playlists with OnTheAir Live, or playlists and schedules with OnTheAir Manager, 
they are stored locally to the client. This means that multiple users can not access the same 
schedules and playlists. With OnTheAir Live, it is relatively easy to overcome, as you can save the 
.vpls playlist to a shared storage and open it from multiple locations. But with OnTheAir Manager 
all is stored in a local database which can not be saved to a shared storage and opened by 
multiple	users	as	it	would	result	in	conflicts	when	multiple	users	will	try	to	modify	the	same	part	
of a schedule.

That is where OnTheAir Server is needed: when you want multiple users to be able to modify the 
same schedules and playlists. The Schedules and playlists will then not be stored locally but on 
the Server which will handle the read/write access to the database for multiple users.

When purchasing a OnTheAir Server license, it entitles you to install any number of OnTheAir 
Manager client applications.

OnTheAir Server



I-9 OnTheAir Live 1.1b3 - User Manual vers 2
Softron Media Services

TO AIR

1.4 X Different possible setups

OnTheAir Video (DV and Express also) is a playout application that needs to be controlled from 
the computer where the application is running. However some usage may require to control the 
playout	from	a	different	computer.	For	example,	if	you	install	the	playout	computer	in	a	Machine	
Room and want to control the playout from the Control Room. With OnTheAir Video this is only 
possible using a Screen Sharing application, or some Apple Scripts. This can work very nicely for 
some users, but is not always the ideal solution (may be a little slow, etc...)

That is why Softron has developed a version of OnTheAir Video that is based on the client-server 
architecture and it is called OnTheAir Node. OnTheAir Node uses the same reliable engine as 
OnTheAir Video, but brings the power of a client-server architecture.

With OnTheAir Video or OnTheAir Video DV or OnTheAir Video Express : 
One client controls one or 2 output but only local: you need to be on the 
computer to control it.

TO AIR

With OnTheAir Node + OnTheAir Manager (or OnTheAir Live) :
One client (OnTheAir Manager or OnTheAir Live) control one output (OnTheAir 
Node) on the same computer.

A/V signals

Network

TO AIR

TO AIR

One client (OnTheAir Manager or OnTheAir Live) control 2 output (OnTheAir 
Node) on the same computer.
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TO AIR

TO AIR

TO AIR

TO AIR

One client (OnTheAir Manager or OnTheAir Live) control multiple output 
(OnTheAir Node) remotely by connecting to the Nodes with Ethernet.

TO AIR

One or multiple output (OnTheAir Node) can be controlled by multiple clients 
(only OnTheAir Live - for OnTheAir Manager you will need OnTheAir Server)
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With OnTheAir Node + OnTheAir Server + OnTheAir Manager :
One and or multiple clients (OnTheAir Manager) control one and or multiple 
output (OnTheAir Node) by connecting to a Server (OnTheAir Server)

A/V signals

Network

TO AIR

TO AIR

TO AIR

TO AIR

TO AIR
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System Requirements

OnTheAir	Live	doesn’t	do	the	output,	(OnTheAir	Node	is	the	application	that	actually	
outputs	the	video)	so	it	doesn’t	require	any	Video	Card	to	be	installed	on	the	computer.

OnTheAir Live requires :
any Intel Computer.•	
Minimum •	 4 GB RAM.
Mac OS X version 10.5.8 or later•	

2.1 X Computer Requirements

2.2 X Video /Audio output

OnTheAir	Live	doesn’t	do	the	output,	(OnTheAir	Node	is	the	application	that	actually	outputs	the	
video)	so	it	doesn’t	require	any	specific	storage	as	the	files	are	located	on	the	computer	where	
OnTheAir	Node	is	installed	(it	can	be	the	same	computer).	If	you	want	to	trim	the	files,	you	will	
need to mount the volumes.

2.3 X Storage

2

OnTheAir	Live	doesn’t	do	the	output,	(OnTheAir	Node	is	the	application	that	actually	outputs	the	
video) sorefer to OnTheAir Node user manual to know about the supported codecs.

2.4 X Supported Codecs - File format
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In this second part, we will explain how to set up the OnTheAir Live preferences.

Please read this section carefully. Not only will it provide valuable information on how to set up 
your hardware and software correctly, but also because much of the information provided will be 
helpful in your every day use of OnTheAir Live.

Installing & Setting up 
OnTheAir Live II
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Installing and licensing
OnTheAir Live

Download it from the download pages of www.softron.tv•	
Unzip	the	file•	
Drag	and	drop	the	file	to	the	“Applications”	Folder•	
Double-click	on	the	file	“OnTheAir	Live”	in	the	Applications	Folder•	
That’s	it•	

3.1 X Installing OnTheAir Live

3

3.2 X Licensing OnTheAir Live

OnTheAir Live is a free application and thus do not need any serial number, nor dongle. the serial 
number or dongle you receive should be installed on OnTheAir Node.
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Setting up OnTheAir Live 4

The	first	tab	of	the	OnTheAir	Live	preferences	window	is	the	General	preferences

4.1 X OnTheAir Live “General” preferences

Default Nodes

Set which Node will be selected by default when you create a new playlist. If you select 2 Nodes 
(one A, and one B), every new playlist that you will create will be in A/B roll mode by default.

Default Offline Clip Duration

You	can	create	offline	clips	in	OnTheAir	Live	playlists.	This	sets	the	default	duration	for	these	
offline	clips	created	in	a	playlist	but	you	will	of	course	be	able	to	change	the	durations	every	time	
you	create	an	offline	clip

Auto Cue

Auto Cue is a feature that is used in Cue mode, and which will automatically cue the next clip 
after	a	defined	time	when	it	reaches	the	end	of	the	clip.	If	you	disable	that	feature,	OnTheAir	Live	
will	hold	the	last	frame	of	the	clip	for	an	undefined	duration	and	you	will	need	a	manual	operation	
(press the space bar, or click on the play button) in order to cue the next clip.

In	A/B	Roll,	it	behaves	a	little	differently	:
when	Auto	Cue	is	on,	and	let’s	say	a	clip	is	playing	on	Node	A,	if	you	start	the	clip	on	Node	B,	•	
it	will	cue	the	next	clip	on	Node	A	after	the	defined	duration
when	Auto	Cue	is	off,	and	let’s	say	a	clip	is	playing	on	Node	A,	if	you	start	the	clip	on	Node	•	
B, it will continue playing the clip on Node A until the end and hold the last frame of the clip 
until you press the space bar or click the play button. It will then cue the next clip on Node A

More info on this in the chapter on how to use OnTheAir Live.
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4.2 X OnTheAir Live “Media Folder” preferences

When you will want to trim a clip OnTheAir Live will need to have access to it. For that, the volume 
where	the	files	are	stored	must	be	mounted	your	Mac.	If	the	path	to	the	files	is	the	same	on	the	
OnTheAir	Node	computer	(which	indexes	the	files)	and	OnTheAir	Live’s	computer,	you	will	not	
need to set any equivalent Local Path, and OnTheAir Live will have access to it.

Only	if	the	path	are	different	on	the	OnTheAir	Node	computer	(which	indexes	the	files)	and	
OnTheAir	Live’s	computer,	or	if	you	want	to	point	to	another	volume/folder	will	you	need	to	set	
this preference.

To add a Equivalent Local Path, click on the + button on the bottom left. This window will show 
up:

Select the Node you want from the list. Then OnTheAir Live will show you the list of Media Folders 
for that Node. Select the one you need and then click on the “Choose...” button to choose the 
folder equivalent to the one selected in OnTheAir Node Media Folders.
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In this third part, we will explain how to use the OnTheAir Live.

Using OnTheAir Live III
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5.1 X Media Browser

1

1 Node Selection
Select which Node you want to see the List of available Media from

2

3

Thumbnail 
Shows the Thumbnail of the selected clip

List of available Media for the selected Node
There is the list of all Media available for the selected Node with informations such as:
the	validity	(will	be	greyed	out	if	not	valid	or	offline),	the	Finder	Label	(set	in	the	Finder),	
the	Duration,	the	Last	Modification	Date,	the	format

2

3

4

4 Number of Selected Items

Overview of the user interface 5
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1

2
3

1 Time Indicators
Will give you information about the Elapsed, duration and remaining time of the current 
clip and/or playlist.

2

3

Node Selection, Playback Controls, Playback Modes 
Node selection: Select the Node where the playlists need to go out to
Playback Controls : Skip to previous, stop, pause, play, skip to next.
Playback Modes: Enable/disable the Chain/Loop/CueA/B Roll Modes

Playlist
The list of clips to broadcast with some quick info about Start Time, Thumbnail, Clip 
Name,	Last	modification	date,	Duration,	Languages,	Clip	End	Behavior,	Logo	On/Off

5.2 X Playlist Overview

4

4 Items Selected
Number and Duration of selected items
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Here	are	the	different	play	modes	:
« Chain »•	  : in this mode, the clips will play one after the other in the order of the playlist. If 
unchecked, OnTheAir Live will stop after each clip.
« Loop »•	  : at the end of the playlist, OnTheAir Live will go back to the beginning and replay 
the playlist. 
« Cue »•	  : when double-clicking on a clip or when selecting a clip and pressing on the space 
bar,	or	clicking	on	“Play”,	instead	of	playing	immediately,	the	clip	will	be	paused	on	the	first	
frame. When pressing the space bar again (or clicking on “Play”), the clip will start to play 
until	the	end	and	hold	the	last	frame	for	the	duration	set	in	preferences,	then	hold	the	first	
frame	of	the	next	clip.	This	is	very	useful	for	News	and	live	shows	when	the	subject	is	ready	
on	the	first	frame.	It	should	be	used	in	combination	with	“Chain	Mode”:	when	“Chain	Mode”	
is enabled, the clips will play one after another; when disabled, OnTheAir Live will stop after 
each clip and select the next one, so that it is ready to be cued.
« A/B Roll »•	  If this option is enabled, it will add one more Node Selection pop up menu to the 
right of your playlist. If you select a Node in this menu, you will see that the User Interface 
changes. This means that : Clip with an orange A to the left will be played from Node A, 
and Clip with a blue B will play from Node B. This option is mainly used for Live productions 
where	the	producer	already	wants	to	have	the	following	subject	ready	to	go	to	air,	or	to	mix	2	
different	clips.

5.4 X Playlist: Playback Settings

The six Play controls are: Play Next Clip, Stop, Pause, Play, Cue Clip, Play Next Clip.

On  the right hand side and left hand side, you also have the Lock and Unlock buttons to take 
control of the Nodes (may require a password)

5.5 X Playlist: Playback Controls

5.3 X Playlist: Selected Node

Select the Node you want to control there.
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The upper numbers of the Timeline provide information about the time (Elapsed Time, Duration, 
Remaining Time) for the entire playlist. The lower numbers indicate this time information for the 
current clip.

The two windows with larger numbers to the left and to the right of this Timeline are Elapsed 
Time and Remaining Time indicators. It is limited to 59 minutes 59 seconds.  Above that limit, it 
indicates --:--. These windows can indicate the Remaining or Elapsed Time for the playlist OR for 
the clip. To change that, right click on the numbers (or ctrl + click) and choose whether you want 
these numbers to indicate the Elapsed or Remaining Time for the Playlist or for the Clips.. 

The numbers in the left window (Elapsed Time) are in grey all the time. The numbers in the right 
window (Remaining Time) are mostly in green, but 30 seconds before 0, they become orange and 
10 seconds before the end they become red.

5.6 X Playlist: Time Indicators

5 6 7

1

2

1 Elapsed, Duration and Remaining 
Time of the playlist

2 Elapsed, Duration and Remaining 
Time of the playing clip

3 Elapsed Time of the Clip or Playlist 
(Control+Click to switch)

4 Remaining Time of the Clip or Playlist 
(Control+Click to switch)

3 4

5 Elapsed Time of the clip and/or 
Playlist

6 Duration of the clip and/or Playlist

7 Remaining Time of the clip and/or 
Playlist
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The playlist is simply a succession of video clips

The	first	column	indicates	the	relative	start	time	of	each	clip.

5.7 X Playlist Clip Cell

The second column shows a thumbnail of the clip.

The third column has 3 lines:
the	Name	of	the	file	(or	the	QuickTime	Title)•	
the Finder Label, with a colored circle and the name of the Label (this must be customized on •	
OnTheAir Node which gives that information), not on OnTheAir Live
the	file	format	information	(codec,	size	of	frame,	frame	rate,	audio	languages	available)•	

The forth column also has 3 lines:
the duration of the clip•	
the	last	modification	of	the	clip•	
the	attributes	area	where	different	icons	can	show	considering	which	attributes	are	set	for	the	•	
clip.

Color Codes in playlists
A clip tinted in •	 blue indicates it is selected.

A clip tinted in •	 green (there will also be a green triangle on the Thumbnail) indicates that the 
clip is now playing.

A clip tinted in •	 red (there will also be a red cross on the thumbnail) indicates that the clip 
is	offline.	Maybe	the	clip	(and/or	the	folder	in	which	it	was)	has	been	moved	or	renamed.	
Be	careful	when	you	move,	rename	or	delete	Files	and/or	folders!	And	remember	that	it’s	
OnTheAir Node that catalog the media that are located in the Media Folder you have set.

A clip preceded by a •	 grey lock	is	a	clip	locked	because	it	is	already	buffered.	This	means	that	
10 seconds before the end of the playing clip, the next clip will be locked.

About Locked Clips
Clips	are	locked	when	they	are	playing	(green)	or	buffered	(grey	lock).	When	clips	are	locked	there	
is a number of operation you can not do:

Move or delete the clip in the playlist•	
Modify in/out points•	
Modify the Attributes•	
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Operations in the playlist
Within the playlists you can perform several operations :

Inserting and ordering the clips by •	 drag-and-drop. With drag-and-drop, the clips are 
inserted at the top of the clip where your pointer is. You can organize the clips, even in a 
playing playlist as long as the clip is not locked.
Copy-paste•	  one or more clips: Select one or more clips in a playlist then press “cmd + C”  or 
select “Edit > Copy”, then in another playlist, or the same playlist, select a clip and then press 
“cmd + V” or select “Edit > Paste”. The copied clips will be pasted at the top of the selected 
clip. You can also Copy-Paste one or more clips by holding the “alt” key while moving a clip 
within a playlist.

Symbols

Clip End Behavior: Stop At End

Clip End Behavior: Hold Last Frame

Clip End Behavior: Play Next clip

Clip End Behavior: Loop

Shows that in and/or out points are set

Shows that Actions are set on the clip
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5.8 X Inspector : Attributes

1

2

3

1

2
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Tool Bar
Select what you want to see/edit: 
“Attributes”, “In/Out”, “Resize”, “Info”.

Built-in Attributes
Modify the Built-in Attributes here: 
Alpha Key, Audio Source, Audio Volume, 
Clip End Behavior, Logo Overlay, Reverse 
field	Order

Custom Attributes
Modify the Custom Attributes. These 
attributes will depend on the plugins (to 
control for example GPI Commander, or 
a Video Router) that are installed on the 
selected Node.

Built-in Attributes

Alpha Key
You can use OnTheAir Node to overlay graphics on top of an incoming signal if you have a video 
card that supports Keying. To check, refer to the Knowledge Base article here:
http://softron.zendesk.com/entries/303926-which-video-cards-can-you-use-to-key
If you enabled the Key on that Node (Keying set to Internal or External in OnTheAir Node Playback 
Preferences), you can then enable or disable keying for each individual clip. Be aware though 
that	every	time	you	will	enable	or	disable	the	key,	the	output	will	jump.	So	we	recommend	not	to	
switch it often.

Audio Source
Select here what will be the source of the audio that will be outputted:

Player : The Audio that will be outputted is the audio of the clips played•	
Audio In: The Audio that will be outputted is the audio that is getting in the selected video •	
input (and coming for example from your studio)

2
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When you modify the value of a clip Attribute (Built-in or Custom), its title becomes in bold, 
showing that the value set there is not the default one

When you modify only the Custom Attributes, this icon appears in the playlist:

Volume
You	can	adjust	the	volume	for	every	clip.	To	adjust	the	volume,	select	one	or	more	clip	and	drag	
the slide bar in the drawer window. 

Clip end Behavior
This option sets the way the selected clip(s) should end:

Normal :•	  the clip will end as it is set in the Playback Mode for the playlist. So if the playlist 
is in Chain Mode, OnTheAir Node will play the next clip, if it is not in Chain Mode, OnTheAir 
Node will stop after playing the clip. If the playlist is in cue Mode, OnTheAir Node will select 
the next clip, ready to be cued.
Stop At End :•	  stops playing completely at the end of the clip.
Hold Last Frame :•	  OnTheAir Node will stay on pause on the last frame.
Play Next Clip:•	  Plays the next clip, even if chain mode is not active.
Loop : •	 OnTheAir Node will go back to the beginning of the clip and play it again.

Overlay Logo
It	is	here	where	you	choose	the	logo	to	overlay	on	one	or	more	clip.	Don’t	forget	that	the	logos	
or	graphics	files	must	be	in	the	folder	indicated	in	the	preferences	and	that	these	files	must	be	
in	png,	tiff	or	psd	and	in	the	resolution	720*576	for	PAL	or	720	x	486	or	720	x	480	for	NTSC,	
1920*1080	for	HD,	72	dpi,	with	an	extension	.png	at	the	end.

To	choose	which	file	is	to	be	overlaid,	select	one	or	more	clips	and	in	the	drawer,	click	on	the	
logo	overlay	pull	down	menu	and	select	the	file	you	want.

If you wish to have more complicated Graphics overlay like, tickers, animated logo, clocks, etc. 
Check our product OnTheAir CG. It can be controlled from OnTheAir Node so you can choose 
when to overlay your graphics as well.

Reverse Field order
If	the	editor	has	exported	the	clip	with	the	wrong	field	priority,	you	can	still	correct	it	here.

Custom Attributes

OnTheAir Node can have Custom attributes which are given by the plugins that you install in the 
plugin folder of OnTheAir Node. There can be multiple plugins such as:

GPI Commander:  to control a GPI Commander USB converter box (to be purchased separately)•	
OnTheAir CG: to control our Character Generator program OnTheAir CG (start, stop, update •	
projects)
Video Router plugin: you can control almost any Video Router provided the plugin is available. •	
We	control	video	routers	using	RS232	but	may	need	to	develop	a	specific	plugin	for	you.	This	
development is free of charge. Contact us before you buy OnTheAir Node to make sure that it 
will be possible to control your router and in which time frame.
etc... it can be almost anything that has to be controlled by the playout. Contact us if you •	
have	some	needs,	we’ll	be	happy	to	talk	about	it.

3
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MovieTime Indicators
«•	  Current Position » : the timecode (start at 00:00:00:00) at the position where the 
playhead is located
«•	  Duration » : the Clip Duration (considering the in/out points)

Preview Window
Video Preview of the Movie

Timeline
Scrub/Play into the Movie (you can use standard JKL and arrows shortcuts to move the 
playhead)

In/Out Points
« •	 In Point » : the timecode where the In Point is set.
« •	 Out Point » : the timecode where the Out Point is set.

To set in and out points, you can
go to a position in the timeline, and use the i and o shortcuts•	
click on Mark, Go, Clear button •	
manually type the Timecode In/Out •	

Beware that these in/out settings are set only for the selected clip in this playlist. It will not 
change	the	in	and	out	points	of	all	the	occurrences.	If	you	want	to	do	that,	you’ll	have	to	
re-export the clip or copy-paste it from one playlist  to another.

4

5.9 X Inspector : In/Out
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5.10 X Inspector : Resize

5.11 X Inspector : Info

Info	is	the	tab	where	you	can	see	different	informations	such	as	the	full	path	of	the	clip,	its	codec.	
This can be very useful if you want to check where a media is located,  etc...

OnTheAir Node has a powerful feature that enables you to resize your video and reposition it 
where	you	want	to.	This	feature	will	require	you	to	Apply	it	once	you	have	modified	one	of	the	
value.

Note for the position that when you set the position to X=0 and Y=0, the frame will be located at 
the top left corner, and that the value indicated is in pixels.
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Be aware that some of the Menus are created automatically for all Mac OS X Applications and 
therefore	are	not	always	used	by	OnTheAir	Node.	Also	these	menus	are	subject	to	change	from	
one version to the other.

New : Creates a new playlist.•	
New from Node : Retrieve the current playlist that is loaded on a Node. This will create a new •	
“Untitled playlist” that will contain all the clips that are scheduled to be played on a Node. See 
the chapter on how to use OnTheAir Live for more informations.
Open : Opens an existing playlist.•	
Open Recent : Opens a list with the 5 last opened playlists among which you will be able to •	
choose.
Close : Closes the current playlist.•	
Save : Saves the current playlist.•	
Save As : Saves the playlist with another name or at another place.•	

Menus Overview

6.1 X Menu File

6.2 X Menu Edit

Undo : Undo an action.•	
Redo : Redo an action after an Undo.•	
Cut : Cut a clip from the playlist (removes it from the playlist and place it in the Clip-board).•	
Copy : Copies the clip (leaves it in the playlist and place it in the clip-board).•	
Paste : Pastes the clip from the Clip-Board. Place it on the top of the selected clip.•	
Delete : Erases the selected clip in the playlist.•	
Select All : Selects all the clips in the same playlist.•	

6

6.3 X Menu Window

Minimize : Minimize the current Playlist window and place it in the Dock.•	
Zoom•	
Bring All To front : Shows all the Playlists that were hidden by other Applications.•	
Media Browser: select this menu to show the “Media Browser” window•	
Clip Inspector: select this menu to show the “Clip Inspector” window•	
At the bottom of this menu, you can also see all the opened Playlists. You can select and show •	
them from here.

6.4 X Menu Help

Search: will search in OnTheAir Node menus and Help topics for the Mac OS•	
OnTheAir Node Help : Opens the OnTheAir Node Manual.•	
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How to create a playlist ?

7.1 X Basics

A playlist is a document that you save on your disk that is “simply” a compilation of clips. The 
extension	of	a	playlist	is	.vpls.	It’s	an	XML	file	with	all	the	information	of	the	clips,	etc...	It	will	
look like that:

7
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Creating playlists is relatively simple. You do so by using drag-and-drop between the media 
browser and a playlist, or between two playlists.  And even from the Finder to the playlist, 
provided the clip is within a media folder of the selected node. The advantage of drag-and-
dropping clips between two playlists is that the clip settings (logo, volume, in/out points...) will 
also be kept.  

To create a new playlist, choose File > New Playlist or press  + N. Then, to place the clips you 
want where you want them, you have several options:

Next	to	the	playlist	window,	open	a	finder	window	(or	another	playlist	window).	From	this	•	
window,	find	the	clips	that	you	want	to	use.	Select	a	clip	(or	many	clips),	hold	the	click	on	it	
and move it in the playlist window, then release the mouse button when it is at the place you 
want it to be. This new clip will go at the top of the selected clip in the playlist where you 
dropped it.
Open two playlists and select one or more clips, then press •	  + C or choose “Edit > Copy”.  
Then	select	the	playlist	in	which	you	want	to	copy	these	files,	and	select	the	clip	on	the	top	of	
which you want to place them. Then press  + V or choose “Edit > Paste”. 
Select the clip on the top of which you want to place the new clips, then press •	  +  + N, or 
choose File > Add. Then select the clip(s) you want to add and press OK.

You can select multiple clips by holding down the Apple key and you can select •	
consecutive clips by holding the shift key.
If a clip is invalid (yellow icon) you will not be able to drop it in a playlist. Check the •	
reason	why	it’s	not	valid	(hold	your	mouse	over	it)	and	correct	it.
Once	a	playlist	is	opened,	and	if	one	of	the	file	becomes	unavailable	(deleted	from	the	•	
disk	or	not	valid	anymore),	it	will	immediately	be	reflected	in	the	playlist.

7.2 X Creating a playlist manually

7.3 X Creating a playlist in ASCII

Using	ASCI	playlist	is	a	very	easy	way	for	an	external	application	to	create	playlists	if	they	don’t	
want	to	bother	creating	an	XML.	An	ASCII	playlist	is	simply	a	Text	file	that	holds	only	the	full	(or	
relative)	path	to	the	clips.	The	text	file	should	look	like	this:
/Volumes/Video/Clips/Clip1.mov
/Volumes/Video/Clips/Clip2.mov
/Volumes/Video/Clips/Clip3.mov
/Volumes/Video/Clips/Clip4.mov
/Volumes/Video/Clips/Clip5.mov
/Volumes/Video/Clips/Clip6.mov
/Volumes/Video/Clips/Clip7.mov
/Volumes/Video/Clips/Clip8.mov

Now	to	open	this	file	in	OnTheAir	Live,	simply	go	in	the	menu	File			>	Import	ASCI	Playlist...

This	will	import	all	the	8	files	in	OnTheAir	Live.	You	will	then	have	to	save	the	playlist	and	reopen	
it in order to use it.
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7.4 X Creating a playlist in XML : Third party integration

Creating a playlist directly in XML (the playlists native format) is a bit more complicated than 
creating	an	ASCII	playlist,	but	so	much	easier	after	(because	it’s	the	native	format	of	OnTheAir	
Live playlists). Also you can add as much information in the XML as if you were doing the playlist 
in OnTheAir Live: you can add Logo, Actions, In/Out points, etc...

To know how to format the OnTheAir Live playlist, the easiest is to create one on your computer, 
save	it,	and	then	right-click	on	the	playlist	file	and	choose	in	the	menu	“Open	With...”	and	then	
open it with any text editor (like Text Edit or Text Wrangler). You will see that there are many 
informations referenced in the XML, but if you create the playlists yourself you do not have to set 
all	the	information	there	(you	don’t	have	to	create	the	thumbnail	for	example).


